OGMem - dein OGame KB-Archivar

    • Website

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    Als Gast sind dir nicht alle Inhalte und Funktionen dieses Forums zugänglich.
    Um das Forum im vollen Umfang nutzen zu können, registriere dich bitte.

    • Tommy wrote:

      Hallo. Ich habe bei Ogame den Namen geändert und möchte es auch bei Ogmen aber es Funktioniert nicht, es bleibt immer gleich.
      Wie auch per E-Mail geantwortet: Wir hatten einen Bug, sodass eine Fehlermeldung (zB weil Benutzername schon vorhanden) bei der Änderung des Nutzernamens nicht angezeigt wurde. Dies ist jetzt behoben. Da dein gewählter Nutzername aber eben schon vergeben ist, musst du dir leider einen anderen ausdenken :(
      OGMem.com - der neue KB-Archivar!

      thx @ Illidan für die Signatur
    • Wir haben in Wezn ein zunehmendes Problem mit FakeAccs bei OGMem die unter fremden Namen KBs zuflamen. Unter anderem bin ich auch betroffen. Gibt es hierfür eine Möglichkeit diese sperren zu lassen oder sonstiges?


      Grüße :-_-:


      Jakob Arjouni wrote:

      „Keine Religion, keine Sternzeichen, keine warmen Steine oder Glückszahlen.
      Wenn ich Halt brauche, nehme ich mir ein Bier.“
    • Moin zusammen,

      wir haben weiterhin Serverprobleme, weswegen wir einen Hardware-Check beim Rechenzentrums-Betreiber angefordert haben. Dieser führt den Check jetzt durch, dadurch sind wir momentan offline. Laut deren Aussage kann der Check bis zu 16 Stunden dauern. Ich hoffe, dass das eine sehr vorsichtige Schätzung von ihm war, dennoch möchte ich mich hiermit schonmal entschuldigen, falls wir wirklich bis 16 Uhr offline sein sollten.

      Vielen Dank für euer Verständnis!
      OGMem.com - der neue KB-Archivar!

      thx @ Illidan für die Signatur
    • Nur hier auch nochmal die Information, auch wenn dies bereits beim Besuchen von OGMem.com zu lesen ist: Wir ziehen momentan auf einen neuen Server um. Die Erfahrungen Anfang März mit Hardware-Problemen haben uns dazu bewogen, eine neue technische Basis für die Infrastruktur von OGMem zu bauen, auf die wir jetzt umziehen. Dies senkt die Ausfallwahrscheinlichkeit für die Zukunft, damit so etwas wie Anfäng März noch nicht einmal passiert.

      Aus diesem Grund sind wir momentan offline, voraussichtlich bis irgendwann samstags in den Morgenstunden.
      OGMem.com - der neue KB-Archivar!

      thx @ Illidan für die Signatur
    • mhmmmm... die Thumbnails werden von Discord erstellt, nicht von uns. Also, Discord kontaktiert unseren Server, wir liefern eine Grafik, und Discord speichert diese zwischen.

      Jetzt kann es natürlich sein, dass wir das Original-Bild nicht schnell genug an Discord liefern, sodass du dann in Discord das Gefühl hast, dass es irgendwie langsam ist oder garnicht mehr lädt... Aber das kann ich mir gerade nicht erklären, woran das liegen sollte. Vor allen Dingen nicht im Zusammenhang mit unserem Server-Umzug.

      Hat noch irgendjemand anderes denn dieses Problem beobachtet, oder ist es ein Einzelfall?
      OGMem.com - der neue KB-Archivar!

      thx @ Illidan für die Signatur
    • Öh.. das kann ich nu nicht so genau sagen. Da während eurer Downzeit der Kackhaufen extrem lange gebraucht hat zu laden, habe ich das subjektive Gefühl, dass es, seit die KBs wieder geladen werden, langsamer ist als davor. Aber da ich davor nicht soo darauf geachtet habe, ist das wie gesagt nur ein Gefühl.
    • DeLord wrote:

      mhmmmm... die Thumbnails werden von Discord erstellt, nicht von uns. Also, Discord kontaktiert unseren Server, wir liefern eine Grafik, und Discord speichert diese zwischen.

      Jetzt kann es natürlich sein, dass wir das Original-Bild nicht schnell genug an Discord liefern, sodass du dann in Discord das Gefühl hast, dass es irgendwie langsam ist oder garnicht mehr lädt... Aber das kann ich mir gerade nicht erklären, woran das liegen sollte. Vor allen Dingen nicht im Zusammenhang mit unserem Server-Umzug.

      Hat noch irgendjemand anderes denn dieses Problem beobachtet, oder ist es ein Einzelfall?
      Ich glaube, dass die Bilder nicht gecached werden Discord agiert Lediglich als Proxy. Warum? Habe genau aus diesem Grund ein Experiment gemacht.

      Ich habe ein Bild auf meinem Webserver in Discord verlinkt. Wenn ich mir nun die Serverlogs anschaue kommt zuerst eine Anfrage vom Discordbot (User Agent: "Mozilla/5.0 (compatible; Discordbot/2.0; +discordapp.com)") rein.
      Wenn ich nun den Server von einem anderen Client aus öffne kann ich immer eine Anfrage auf genau dieses Bild beobachten. Hierbei ist zu beachten, dass die IP Adresse eine andere ist als die von mir (Daher Proxy). Der User Agent dieser nachfolgenden Anfragen ist: "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0" Die ersten drei Bytes der IP waren auch immer gleich, da das vierte Byte zur Anonymisierung gelöscht wird kann ich nicht sagen ob das anders ist.

      Da der Domainame zuvor noch nie verwendet wurde, muss ich davon ausgehen, dass die Anfragen durch Discord ausgelöst wurden. Finde es aber auch ein wenig Dubios warum man FF 38 auf MacOS als User Agent wählt...

      Daher würde ich vermtuen, dass Discord kein Caching vornimmt. Was eventuell dazu führen kann das der Server nicht hinterherkommt. Nen 100% "beweis" hab ich aber nicht...
      Inkompetenz ist meine Kernkompetenz.

      The post was edited 1 time, last by Der Unfaehige ().

    • Habe das jetzt mal überprüft (vorher nur zusammengereimt), stimmt, scheint als hättest du Recht. Discord proxied hier nur, speichert nicht zwischen.

      Das erklärt aber nicht, wieso es auf einmal (bei manchen Leuten?) langsamer lädt. Bei mir zB sieht alles gut aus, ein von Discord proxied Bild lädt bei mir in 25ms.

      Was ich jedoch im Access Log sehe, ist, dass ein paar Requests von Discord reinkommen, die auf nicht mehr öffentliche Kampfberichte verweisen. Momentan löst dies einen 303 Redirect auf die Startseite von OGMem aus, den Discord aber nicht verfolgt, und stattdessen immer wieder versucht, das Bild zu requesten. Vielleicht sollten wir das mal ändern, sodass dann stattdessen dort ein Platzhalter-Bild oder so ausgeliefert wird.

      Davon einmal abgesehen, hat das nichts mit dem Server-Umzug zu tun. Diese Sachen waren vorher auch schon so, und hieran hat sich nichts geändert. Vielleicht bin ich hier also auf dem Holzweg?
      OGMem.com - der neue KB-Archivar!

      thx @ Illidan für die Signatur
    • Wenn dieses Quickimage (so heissts glaub) schnell genug generiert wird kommt das Problem aus einer anderen Quelle. Gibt da einige (potentielle) Verursacher die nicht ihr seid (Meine ISP, Discord...).

      Ein manuelles Quickimage Request dauert bei mir zw. 200 und 400 ms (Getestet mit: "curl -v ogmem.com/cr/quickimage/603636 >> /dev/null"). Ob das für dDscord ausreicht. Keine Ahnung.
      Inkompetenz ist meine Kernkompetenz.